Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
A few questions, comments about variables, Subnet Mask, passwords
#1
first, i use the command line option to save a CSV file. I then take this CSV file and run it it through AWK then GROFF on my Linux server to generate a machine information report, this work really well.

However I noticed in the last few version updates, you have changed the variable names, for example on a previous version i would get the following line:

"SOME-PC","OS Name","Windows 7 Home Premium","Name","Windows 7 Home Premium x64 Service Pack 1"

However, now after updateing, i get this:

"SOME-PC","Operating System","Windows 7 Home Premium","Name","Windows 7 Home Premium x64 Service Pack 1"

which messes up my AWK script, I don't suppose there is a way for me to define the variables so that when they are exported, they will remain the same...

Also, under the "Extended Network Information" i see the we have IP address, gateway, and DHCP Enabled, but i don't see the Subnet mask. is it not being exported, or do i need to turn on another switch?

And lastly, i completely understand why you don't export passwords. perhaps with only the paid versions? this would really help when they call and ask "I forgot my email password"

Thanks, this is really a great product!!
Reply
#2
(11-27-2013, 09:39 AM)mtsoule Wrote: first, i use the command line option to save a CSV file. I then take this CSV file and run it it through AWK then GROFF on my Linux server to generate a machine information report, this work really well.

However I noticed in the last few version updates, you have changed the variable names, for example on a previous version i would get the following line:

"SOME-PC","OS Name","Windows 7 Home Premium","Name","Windows 7 Home Premium x64 Service Pack 1"

However, now after updateing, i get this:

"SOME-PC","Operating System","Windows 7 Home Premium","Name","Windows 7 Home Premium x64 Service Pack 1"

which messes up my AWK script, I don't suppose there is a way for me to define the variables so that when they are exported, they will remain the same...

Also, under the "Extended Network Information" i see the we have IP address, gateway, and DHCP Enabled, but i don't see the Subnet mask. is it not being exported, or do i need to turn on another switch?

And lastly, i completely understand why you don't export passwords. perhaps with only the paid versions? this would really help when they call and ask "I forgot my email password"

Thanks, this is really a great product!!

1. OS Name issue
Tse the siw.lng language file (see SIW Languages page), change "&Operating System=" to "&Operating System=OS Name"

2. Extended Network Information issue
Tools --> Options --> Detailed Reports

3. Passwords
No Comment
Reply




Users browsing this thread: 1 Guest(s)