Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Upload zipped report FTP
#11
Alright, I will try a workaround and tell you if I found something.

Thanks for the time.
Reply
#12
Alright I finally managed to send the report passive through firewall without touching the configuration

First of all: The standard Microsoft Windows FTP://exe does NOT support passive FTP

Therefore I take some different tool. I have chosen NCFTP Client , it is freeware and open source (client! not server)
You can get it from : http://www.ncftp.com/download/

For sending a file you only need the ncftpput.exe from the archive.

My SIW is installed locally in C:\SIW so i also copied the ncftpput.exe to this directory.

My batch script looks like this(content of C:\siw\start.bat):

set SIWFILENAME=%COMPUTERNAME%_%DATE%_%TIME:~0,2%%TIME:~3,2%%TIME:~6,2%
C:\siw\siw.exe /log:xml=C:\b4\siw\%SIWFILENAME% /silent /zip
C:\siw\ncftpput -u user -p password -R http://ftp.yourserver.com /remoteDirecotry C:\siw\%SIWFILENAME%.xml.zip

please note the single space between http://ftp.yourserver.com and the /remoteDirectory

if you dont like the SIWFILENAME-thing this is the simple way:

C:\siw\siw.exe /log:xml=C:\b4\siw\report /silent /zip
C:\siw\ncftpput -u user -p password -R http://ftp.yourserver.com /remoteDirecotry C:\siw\report.xml.zip

executing the file start.bat will create zipped xml report in C:\siw and send it to http://ftp.yourserver.com into directory remoteDirectory


edit: somehow i cant turn off this auto hyper-link. all of this ftp. yourserver. com is without http:// prefix
Reply




Users browsing this thread: 1 Guest(s)